Page 1 of 1

engine problem

Posted: Fri Mar 20, 2009 7:44 pm
by conni
hi all
just brought a boat with a ford 1800 turbo diesel engine,started first time,then went out on the water for an hour and a hose came off of the heat exchanger,so had to come in very slowly while a friend held the hose on when we got back to the mooring the boats engine stooled and has not started since,
we're getting fuel to the glow plugs and there is heat at plugs ,timming as been checked and is ok, new batteries,actually did start for a few seconds today but cut out again,any advise welcome thanks

hi

Posted: Fri Mar 20, 2009 7:51 pm
by griegwwr
when the hose come off did any of the electrics get wet

Posted: Fri Mar 20, 2009 8:09 pm
by conni
yes they probably did any idea what i can do to solve the prob
cheers

Posted: Fri Mar 20, 2009 8:13 pm
by westy
does it turn over mate??

Posted: Fri Mar 20, 2009 8:26 pm
by conni
turns over ok ,sounds like its going to go but just doesn't,did start for a few seconds but that was it

Posted: Fri Mar 20, 2009 8:37 pm
by westy
fone d m marine of brightlingsea top bloke he will come to you

Posted: Tue Mar 24, 2009 7:54 pm
by reflection
Couple of things for you to check.

When you turn the engine over see if there is any smoke from the exhaust if not water could have shorted the engine kill solenoid so check that connection
And also make sure the fuel pump is delivering to the injector pump.
Check for any air in the system.

ENGINE

Posted: Wed Mar 25, 2009 12:17 pm
by conni
CHEERS EVERYONE
I've now got a diesel fitter to sort it.

Posted: Sat Apr 04, 2009 8:54 am
by meathead
Sounds to me conni like you you have purchased a pile of crap. Best place for that boat is bottom of the river - know what i mean ;)

Posted: Sat Apr 04, 2009 10:09 am
by conni
cheers paul (meathead)
once the engine is in ~X( (only another couple of hundred of pounds each)
this baby going to be loaded up with thornies and bass and i have know doubt you'll be on there trying your best,you chadder