Page 1 of 1

daiwa 7ht meg do i have a problem ???

Posted: Mon Dec 06, 2010 2:24 pm
by bigwobs
hi ,,not sure if this is just me but when i click in the button on reel to cast its ok but when i start to reel back in so the button comes back out it seem to take while to come back out 10 to 12 click b for its out again not been fishing for awhile so not sure if its just me lol or maybe something wrong just dont remeber it taking this long lol,,, any thought or idears ,,thanks,,chris

Posted: Wed Dec 08, 2010 12:48 pm
by bigwobs
ok thanks for that ,,reel_wizard,, i will have alook on line as you say i have a problen but i think i will also take it to my local tackle shop now to b on the safe side lol as i no nothing about the inside of the reel lol but thanks again ,,,chris

Posted: Thu May 12, 2011 10:07 am
by andy1_i

Posted: Sun Jul 31, 2011 9:28 pm
by sparkyman
Breakaway tackle also sell a support sleeve for the 7HT range. Its a simple fit from outside the reel (no need to disassemble). Remove the handle nut retainer and nut, followed by the shaft circlip & washer (no need to even remove the handle if you dont want to). The support sleeve is inserted over the shaft spindle, pushed into the hollow main gear shaft itself- it's a 2 minute job. There's a vidoe showing the procedure;

http://www.breakaway-tackle.co.uk/index ... uct_id=499

I also have a new 7HT Mag that, after maybe a dozen or so casts, would not click back into gear. I found the sliding wishbone assembly "sticky", it's a fairly complex assembly relying on tension springs and sliding faces. Like Reel Wizard metioned, I too thought the problem was due to "sticky" grease on the two assembly "feet" that silde, under pressure, against the inside of the casing. I stripped, cleaned and re-lubed everything with a finger smear of GreaseXtra (an "oily" Grease) and I've had no problems since - in fact it actually seems to re-engage now within half a turn of the handle (I'm sure it took a turn or two to re-engage before....I may be wrong?)